Code Fix: Slow performance experienced when starting a workflow where the start option is based on a SharePoint event

  • 16 February 2021
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Code Fix: Slow performance experienced when starting a workflow where the start option is based on a SharePoint event

KB001822

PRODUCT
K2 blackpearl 4.7
K2 smartforms 4.7
BASED ON
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue Description
When creating a K2 for SharePoint application, including a workflow with the option to start when a SharePoint event occurs, the workflow takes a long time to start after the SharePoint event is executed.

Cause
One call per SmartObject was executed which results in high load volume.

Repro Steps

  1. Create a Custom List with forty Choice columns.
  2. Add one or two Lookup columns.
  3. Integrate the list with K2 to create Data and Workflow.
  4. Select a SharePoint event, such as “Add new item” as the Start Option for the workflow.
  5. Add a Placeholder event and Deploy the workflow.
  6. Add a new item in the Custom List to start a new instance.
  7. Notice it will take more than five minutes for the workflow to start.

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Install the K2 4.7 February 2017 Cumulative Update.
  3. Get the K2 4.7 February 2017 Cumulative Update FP2 from Regional Support.
  4. Install the K2 4.7 February 2017 Cumulative Update FP2 to apply the fix.
 

 


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