Code Fix: Inconsistency in the Drop – Down List control value selection

  • 16 February 2021
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Code Fix: Inconsistency in the Drop – Down List control value selection

KB001879

PRODUCT
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue Description
When the Drop – Down List control selection is based on a comparison with a value in a specific case, such as upper case, but the values in the drop-down are based on data from a data source that returns values with varying cases, results in the drop-down selection are inconsistent when the drop-down data is refreshed.

Cause
The comparison functionality applied during the drop-down selection was case sensitive.

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Install the K2 4.7 February 2017 Cumulative Update.
  3. Get the K2 4.7 February 2017 Cumulative Update FP8 from Regional Support.
  4. Install the K2 4.7 February 2017 Cumulative Update FP8 to apply the fix.

 


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