Code Fix: Emails fail to send when a generic email address is used in a rule action

  • 16 February 2021
  • 0 replies
  • 6 views

Badge +6
 

Code Fix: Emails fail to send when a generic email address is used in a rule action

KB001949

PRODUCT
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

After upgrading to K2 4.7, emails no longer send when a generic email address is configured in the from address field on a Send an email rule action in SmartForms.

 

 

Cause

The issue was caused by security enhancements introduced in K2 4.7.

 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 May 2017 Cumulative Update FP9 from Regional Support.
  4. Install the K2 4.7 May 2017 Cumulative Update FP9 to apply the fix.
  5. Clear your browser cache.
  6. Add the following entry under the appSettings section in the [INSTALLDIR]K2 smartforms DesignerWeb.config:
    <add key="Forms.Runtime.Email.RevertToSMTP" value="true"/>
  7. Add the following entry under the appSettings section in the [INSTALLDIR]K2 smartforms RuntimeWeb.config:
    <add key="Forms.Runtime.Email.RevertToSMTP" value="true"/>

 


0 replies

Be the first to reply!

Reply