Code Fix: Using the picker control on a Form on a mobile device results in part of the Form not rendering

  • 16 February 2021
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Code Fix: Using the picker control on a Form on a mobile device results in part of the Form not rendering

KB001960

PRODUCT
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

When using a scrollable Form on an iOS mobile device, after selecting a date from the picker control, the bottom of the Form is cut off. The Form only displays correctly after a refresh, however the refresh changes all selected values back to default values.

 

 

Cause

Missing styling on iOS Mobile system.

 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 May 2017 Cumulative Update FP10 from Regional Support.
  4. Install the K2 4.7 May 2017 Cumulative Update FP10 to apply the fix.
  5. Clear the browser cache.

 


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