Delay experienced in resolving users and groups in the Identity table

  • 16 February 2021
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Code Fix: Delay experienced in resolving users and groups in the Identity table

KB001994

PRODUCT
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

A timeout error occurs in the Host Server log file when the Identity Service is running a bulk operation. This causes a delay in resolving users and groups in the Identity table.

 

 

Error Message

A timeout error occurs.

 

 

Cause

The timeout error occurs due to a Command Timeout value in the Identity Service which does not allow for a large dataset to be inserted.

 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and install the K2 4.7 August 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 August 2017 Cumulative Update FP1 from Regional Support.
  4. Install the K2 4.7 August 2017 Cumulative Update FP1 to apply the fix.

 


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