Code Fix: The K2 Service takes a long time to stop or start

  • 16 February 2021
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Code Fix: The K2 Service takes a long time to stop or start

KB002319

PRODUCT
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

In a K2 environment with many licensed users, when the K2 Service is stopped or started it takes a few minutes to complete the change.

Cause

Legacy issue, the K2 Server loaded the registered licensed users into memory but did not use the data as Licensing is now handled by the K2 Host Server

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and Install the K2 4.7 March 2018 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 March 2018 Cumulative Update FP4 from Regional Support.
  4. Install the K2 4.7 March 2018 Cumulative Update FP4 to apply the fix.

 


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