Code Fix: Updating a SharePoint item multiple times in Runtime presents an error

  • 16 February 2021
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Code Fix: Updating a SharePoint item multiple times in Runtime presents an error

KB002511

PRODUCT
K2 Five 5.0
K2 Five (5.0) Fix Pack 28
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

When you update a SharePoint item multiple times using K2 smartforms in Runtime an error is presented

Error Message

The following error occurs: “Version conflict”

Cause

SharePoint caches list items client side and if this item gets updated indirectly (such as adding or removing attachments) the cached version of the list item is out of sync with the version of the item on SharePoint server.

Resolution

  1. Ensure you have K2 Five RTM installed.
  2. Get the K2 Five RTM FP28 from Regional Support.
  3. Install the K2 Five RTM FP28 to apply the fix.
  4. It is recommended to refresh the browser cache.
  5. You should now be able to continue working on your form without the error.

 


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