Code Fix: Line breaks added to email body when received from the Rich text control editor

  • 16 February 2021
  • 0 replies
  • 30 views

Badge +5
 

Code Fix: Line breaks added to email body when received from the Rich Text control

KB002540

PRODUCT
K2 Five 5.0
K2 Five (5.0) Fix Pack 30
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

When you send an email using K2 smartforms with text from a Rich Text control as the body of the email, line breaks get added to the email which makes the message render incorrectly.

Cause

There are invisible carriage return characters at the end of each line of HTML being processed by the Rich Text control editor.

Resolution

  1. Ensure you have K2 Five RTM installed.
  2. Get the K2 Five RTM FP29 from Regional Support.
  3. Install the K2 Five RTM FP29 to apply the fix.
  4. It is recommended to refresh the browser cache.

Considerations

This fix will not effect emails that have already been sent, only newly sent Emails will be fixed.

 


0 replies

Be the first to reply!

Reply