K2 Appit for SharePoint: Integration and Compatibility Matrix

spacer Support Plans & Software Releases
spacer spacer Web Browser Compatibility
spacer
spacer Product Integration Compatibility
spacer Additional Resources
How to use this matrix

Use this matrix to determine what products and versions of products are supported and compatible with versions of K2 Appit for SharePoint. A check mark means that the listed product/version was tested and is supported by K2. If any product or version is not listed and not covered by the Product Support Policy, it is not supported. A missing check mark means that the listed product/version is not supported, has not been tested or is not compatible with that specific version of K2 Appit for SharePoint. See the K2 blackpearl and K2 smartforms: Product Compatibility, Integration and Support matrix for what is supported in K2 blackpearl.

This matrix was last updated on 6 March 2017. Access the archived version of the K2 Appit for SharePoint matrix to view support information for previous K2 Appit for SharePoint versions.

Product Integration Compatibility
This section describes the products that can integration with K2 Appit for SharePoint, along with the version compatibility.
Microsoft Products
Microsoft SharePoint K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • Appit supports SharePoint Online only (with the exception of SharePoint on-premises environments that were integrated with Appit before 31 August 2016)
  • The K2 Appit for SharePoint App and SharePoint 2013 Service Broker is used to interact with SharePoint items using the SharePoint CSOM/REST services. This includes interaction with List Items, Documents, Folders, List Item Attachments and also provides Read operations for SharePoint taxonomy and Managed Metadata. Service Instances are configured per Site Collection, and can only be created through the K2 Appit for SharePoint App. To learn more, see the Appit product documentation.
SharePoint Online Check Check
  • Sites that were originally created in BPOS-S that were later migrated to SharePoint Online do not support the SharePoint App model and therefore are not supported by K2.
  • O365 editions supported include Business Essentials, Premium; Enterprise E1 or greater; Education E1 or greater; Government E1 or greater; SharePoint Online Standalone Plan 1 or greater.
Microsoft SQL Server K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • Use the SQL Server Service Broker to integrate with Microsoft SQL Server databases by exposing Tables, Stored Procedures and Views as Service Object and SmartObjects. The available methods will depend on the type of SQL entity being exposed. Service Instances are configured per Database. To learn more, see the Appit SQL Server product documentation.
  • All editions of SQL Server are supported.
Azure SQL Server Check Check
SQL Server 2016 (RTM) Check
SQL Server 2014 (RTM) Check Check
SQL Server 2012 (SP2) Check Check
SQL Server 2012 (SP1) Check Check
SQL Server 2012 (RTM) Check Check
Microsoft Dynamics CRM K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • Use the CRM Service Broker to integrate with CRM Organizations and the entities within those Organizations. To learn more, see the Appit CRM product documentation.
CRM 2016 (Online) Check Check
CRM 2016 (RTM) Check Check
CRM 2015 (Online) Check Check
CRM 2015 (RTM) Check Check
CRM 2013 (Online) Check Check
CRM 2013 (RTM) Check Check
Microsoft Azure Active Directory K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • Integrate with Microsoft Azure Active Directory (AAD) with the Azure Active Directory Service Broker to perform actions like creating and updating user accounts in AAD, amongst others. To learn more, see the Appit AAD product documentation.
Azure Active Directory Online Check Check
  • Tested on the latest update available during the release cycle.
  • All editions of Azure Active Directory (Free, Basic, Premium) are supported.
Non-Microsoft Product Integration
DocuSign K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
DocuSign API Version Check
(REST API v2)
Check
(REST API v2)
Endpoint Service Brokers K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • The generic Endpoint service brokers can be used to expose APIs and services by various technologies as SmartObjects.
REST Services Check Check
WCF Services Check Check
  • Expose WCF (WSDL and MEX) Endpoints as service objects. Users serialization and deserialization to handle complex types.
  • Product Documentation: Endpoints WCF Service
Web Services Check Check
  • Expose web services (WSDL) as service objects. Uses serialization and deserialization to handle complex types.
  • Product Documentation: Endpoints Web Service
  • TLS 1.0 is supported for Appit 1.5 and TLS 1.0 up to TLS 1.2 is supported for Appit 1.5 Update 3 for the Web Services broker.
Mobile Apps Operating Systems K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • Supported mobile operating systems for K2 mobile applications
  • Product Documentation: Learn more about K2 Mobile applications at help.k2.com/mobile
  • For information on Mobile Browser support, please see Mobile Browsers
iOS 10 or later Check Check
Windows Phone 8 or later Check Check
Android 4.1 (Jellybean) Check Check
Browser Compatibility
This section lists the tested web browsers which are used in the following ways:
  • Design-time: Designing artifacts using K2 browser-based design tools.
  • Runtime and Mobile: Using K2 website, worklists and SmartForms in a web browser or a mobile app.
Browser Compatibility
Design-time K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • "Design-time" refers to using the available K2 browser-based design tools to build workflows, SmartObjects, SmartForms and other K2 artifacts. Typically, these actions are performed by application builders. This table lists the web browsers that have been tested against this design-time usage of K2.
  • Microsoft ended support for IE 8 through 10 on 12 January 2016. Please see Internet Explorer Support for more details on what this means for K2 support.
Internet Explorer (11) Check Check
Chrome 53.0.2785.101 m 50.0.2661.94m
  • We always test on the latest released versions of Chrome, Firefox. The versions listed are the versions tested at the release of the Appit version.
Firefox 48.0.2 46.0.1
  • We always test on the latest released versions of Chrome, Firefox. The versions listed are the versions tested at the release of the Appit version.
Safari (MacOS) 9.1.2 9.1.2
Silverlight (5) Check Check
  • Appit 1.5 Update 3 and earlier environments require Silverlight to run the K2 View Flow Report.
  • Appit 1.5 Update 4 and later no longer requires Silverlight to run the K2 View Flow Report. The report renders using HTML5.
Runtime K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • "Runtime" refers to using web browsers to interact with K2 artifacts (for example SmartForms) or administering K2 through the available web-based administration tools. Typically, these actions are performed by end users and system administrators. This table lists the web browsers that have been tested against this runtime use of K2.
  • Microsoft ended support for IE 8 through 10 on 12 January 2016. Please see Internet Explorer Support for more details on what this means for K2 support.
Internet Explorer (11) Check Check
Chrome 53.0.2785.101 m 50.0.2661.94 m
  • We always test on the latest released versions of Chrome, Firefox. The versions listed are the versions tested at the release of the Appit version.
Firefox 48.0.2 46.0.1
  • We always test on the latest released versions of Chrome, Firefox. The versions listed are the versions tested at the release of the Appit version.
Safari (MacOS) 9.1.2 9.1.2
Silverlight (5) Check Check
  • Appit 1.5 Update 3 and earlier environments require Silverlight to run the K2 View Flow Report.
  • Appit 1.5 Update 4 and later no longer requires Silverlight to run the K2 View Flow Report. The report renders using HTML5.
Mobile (Runtime) K2 Appit for SharePoint 1.5 K2 Appit for SharePoint 1.4
  • K2 has tested runtime interaction with K2 artifacts on a variety of mobile browsers, as listed in the table below. Note that only runtime usage of Appit (for example interacting with SmartForms) is supported on mobile devices: no design time usage is supported for mobile devices.
iOS (Safari Browser) iOS 9 iOS 9
  • Includes iPhone and iPads
Windows Devices (Native Browser) 8.1 and 10 8.1 and 10
Android (Native Browser) 4.2.2 4.2.2