< class="prominent-subhead ">

Product Compatibility, Integration and Support

~~repeating-content.html~~
spacer Support Plans & Software Releases
spacer spacer Web Browser Compatibility
spacer
spacer Installation Compatibility
spacer Product Integration Compatibility
spacer
spacer Languages
spacer Additional Resources
How to use this matrix
Use this matrix to determine what products and versions of products are supported and compatible with various versions of K2. A check mark means that the listed product/version is supported by K2. If any product or version is not listed and not covered by the Product Support Policy, it is not supported. A missing check mark means that the listed product/version is not supported with that specific version of K2.

This matrix was last updated 10 September 2020.
Product Support Policy and Release Strategy

Archived compatibility, integration, and support matrices
The matrix below does not include compatibility, integration, or support information on product versions prior to K2 blackpearl 4.7. See the following archive matrices for legacy versions:
Software Releases
This section contains the release history and upgrade compatibility tables for K2 products.
K2 Product Version Release History
spacer
The K2 Product Version Release History table lists the version release history for recent K2 product versions. Refer to the Release Notes links for more information about that release. The article K2 Product Releases and Build Numbers (KB001421) contains a complete list of K2 releases and builds, and the article K2 Product Support and Release Strategy lists the support lifecycle for different products and releases.
K2 Version Build Number Release Date Release Notes
K2 Nexus Platform
K2 Nexus Platform (June) 5.1012.1000.x June 2020 User Guide
K2 Cloud
K2 Cloud (Update 11) 5.1011.1000.x February 2020 User Guide
K2 Platform Classic
K2 Platform Classic (5.4) 5.0005.1000.x June 2020 KB003510
K2 Five
K2 Five (5.3) 5.0004.1000.x May 2019 KB002966
K2 Five (5.2) 5.0003.1000.x October 2018 KB002606
spacer
Show previous versions...
K2 Cloud
K2 Cloud (Update 10) 5.1010.1000.x October 2019 User Guide
K2 Cloud (Update 9) 5.1009.1000.x August 2019 User Guide
K2 Cloud (Update 8) 5.1008.1000.x April 2019 User Guide
K2 Cloud (Update 7) 5.1007.1000.x January 2019 User Guide
K2 Cloud (Update 6) 5.1006.1000.x October 2018 User Guide
K2 Cloud (Update 5) 5.1005.1000.x July 2018 User Guide
K2 Cloud (Update 4) 5.1004.1000.x April 2018 User Guide
K2 Cloud (Update 3) 5.1003.1000.x February 2018 User Guide
K2 Cloud (Update 2) 5.1002.1000.x January 2018 User Guide
K2 Cloud (Update 1) 5.1001.1000.x November 2017 User Guide
K2 Cloud (RTM) 5.1000.1000.x October 2017 User Guide
K2 Five
K2 Five (5.1) 5.0002.1000.x April 2018 KB002301
K2 Five (5.0) 5.0001.1000.x November 2017 KB002044
4.7 September 2016 KB001745
K2 blackpearl 4.7 (includes K2 for SharePoint) 4.16060.2000.x
K2 smartforms 4.7 (includes K2 smartforms Control Pack) 4.16060.2000.x
K2 Language Pack 4.7 (Preview) 4.13500.0.x
4.6.11 September 2015 KB001735
K2 blackpearl 4.6.11 4.12060.1731.x
K2 smartforms 4.6.11 4.12165.1732.x
K2 smartforms Control Pack 4.6.11 4.13180.1733.x
K2 for SharePoint 4.6.11 4.13350.1734.x
K2 Language Pack 4.6.11 (Preview) 4.13500.0.x
4.6.10 June 2015 KB001700
K2 blackpearl 4.6.10 4.12060.1690.x
K2 smartforms 4.6.10 4.12165.1700.x
K2 smartforms Control Pack 4.6.10 4.13180.1710.x
K2 for SharePoint 4.6.10 4.13350.1720.x
K2 Language Pack 4.6.10 (Preview) 4.13500.0.x
4.6.9
K2 blackpearl 4.6.9 4.12060.1640.x February 2015 KB001640
K2 smartforms 4.6.9 4.12165.1650.x February 2015 KB001650
K2 smartforms Control Pack 4.6.9 4.13180.1675.x March 2015 KB001675
K2 for SharePoint 4.6.9 4.13350.1660.x March 2015 KB001660
K2 Language Pack (Preview) 4.6.9 4.13500.0.x March 2015 KB001695
4.6.8 August 2014 KB001600
K2 blackpearl 4.6.8 4.12060.1600.x
K2 smartforms 1.0.7 4.12165.1635.x KB001635
K2 smartforms Control Pack 1.0.1 4.13180.1670.x KB001670
K2 for SharePoint 1.0.1 4.13350.1645.x KB001645
4.6.7 March 2014 KB001590
K2 blackpearl 4.6.7 4.12060.1590.x
K2 smartforms 1.0.6 4.12165.1625.x KB001625
K2 smartforms Control Pack 1.0 4.13180.1.x KB001630
K2 for SharePoint 1.0 4.13350.1.x KB001610
4.6.6
K2 blackpearl 4.6.6 4.12060.1560.x July 2013 KB001560
K2 smartforms 1.0.5 4.12165.1605.x December 2013 KB001605
4.6.5
K2 blackpearl 4.6.5 4.12060.1550.x April 2013 KB001550
K2 smartforms 1.0.4 4.12165.1595.x September 2013 KB001595
4.6.4
K2 blackpearl 4.6.4 4.12060.1540.x December 2012 KB001540
K2 smartforms 1.0.3 4.12165.1585.x July 2013 KB001585
4.6.3
K2 blackpearl 4.6.3 4.12060.1530.x October 2012 KB001530
K2 smartforms 1.0.2
More...
4.12165.1575.x May 2013 KB001575
  • The K2 smartforms 1.0.2 (4.12165.1575.0) release plus the Week 22 patch is equivalent to the K2 smartforms 1.0.2 (4.12165.1575.1) release.
4.6.2
K2 blackpearl 4.6.2 4.12060.1520.x August 2012 KB001520
K2 smartforms 1.0.1 4.12165.1565.x October 2012 KB001565
4.6.1
K2 blackpearl 4.6.1 4.12060.1500.x June 2012 KB001500
K2 smartforms 1.0 4.12165.1.x July 2012 KB001555
4.6 April 2012 KB001450
K2 blackpearl 4.6 4.12060.1.x
Release Upgrade Compatibility
spacer
This upgrade compatibility matrix describes which versions of K2 ("Installed K2 version") can be upgraded to which later versions of K2 ("Version to be installed").
More...
If you have K2 installed with the K2 database in Azure SQL, you must upgrade to the next version of K2 versus jumping versions. For example, if you are on K2 blackpearl 4.7 and you wish to upgrade to K2 Five (5.3), you must first upgrade to K2 Five (5.0), then upgrade to K2 Five (5.1), then K2 Five (5.2), and finally, K2 Five (5.3).
spacer Version to be installed
spacer K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0)
Installed K2 version
K2 Five (5.3) Check
K2 Five (5.2) Check Check
K2 Five (5.1) Check Check Check
K2 Five (5.0) Check Check Check Check
K2 Blackpearl 4.7 Check Check Check Check Check
None Check Check Check Check
Installation Compatibility
This section describes the platforms and software components that are required for installing K2, including optional K2 components. Other optional integration components (such as Microsoft Dynamics CRM or Microsoft Exchange Server) are covered in the Product Integration section.
Uncheck the K2 product versions you do not want displayed. Check the K2 product versions you want displayed.
Supported Products Support Ended Products
K2 Platform Classic (5.4) K2 Five (5.1)
K2 Five (5.3) K2 Five (5.0)
K2 Five (5.2) 4.7
Prerequisites and Installation Compatibility Matrix
spacer
K2 Server Components
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • K2 server components include: K2 Core, K2 Server, K2 database, K2 for SharePoint, and K2 Sites.
  • The K2 Five installer may prevent installation or upgrade if an unsupported operating system is detected.
  • K2 server components are only compatible with 64-bit operating systems.
  • The default IIS version available with a version of Windows is supported for each supported version of Windows.
  • K2 4.7 introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: Third-party support with the K2 4.7 release for more information.
  • K2 Five introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: K2 Five and Supported Technologies for more information.
  • OS language support: K2 server components can be installed on any operating system language. The following operating system languages have been tested: English, Chinese (simplified and traditional), German, and French.
  • See the ICG (Installation and Configuration Guide) topic: K2 Server Components for more information.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
Windows Server 2019 Check Check
Windows Server 2016
More...
Check Check Check Check Check Check
  • Standard with Desktop Experience, Datacenter with Desktop Experience.
Windows Server 2012 R2
More...
Check Check Check Check
  • Standard with Desktop Experience, Datacenter with Desktop Experience.
Windows Server 2012
More...
Check Check Check Check
  • Standard with Desktop Experience, Datacenter with Desktop Experience.
Windows 10
More...
Check Check Check Check Check Check
  • Professional, Enterprise.
Windows 8 (8.1)
More...
Check Check Check Check
  • K2 version 4.6.7 or greater: K2 server components are supported on desktop operating systems, such as Windows 7, for developer licenses or console mode only.
K2 Client Components
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • K2 client components include: K2 Core, K2 Studio, K2 for Visual Studio, and K2 SmartForms wizards for K2 Studio/K2 for Visual Studio.
  • The K2 Five installer may prevent installation or upgrade if an unsupported operating system is detected.
  • K2 client components are compatible with 32-bit and 64-bit operating systems.
  • See the ICG (Installation and Configuration Guide) topic: K2 Client Tool installation: Package and Deployment for more information.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
Windows Server 2019 Check Check
Windows Server 2016 Check Check Check Check Check Check
Windows Server 2012 R2 Check Check Check Check
Windows Server 2012 Check Check Check
Windows 10 Check Check Check Check Check Check
Windows 8 (8.1) Check Check Check Check
Microsoft SQL Server
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • This table lists the versions of Microsoft SQL Server that are supported for installation of the K2 database.
  • The K2 Five installer may prevent installation or upgrade if an unsupported SQL version or unmet minimum required version/edition is detected.
  • K2 4.7 introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: Third-party support with the K2 4.7 release for more information.
  • K2 Five introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: K2 Five and Supported Technologies for more information.
  • K2 blackpearl 4.7 and greater requires consolidated databases (K2 Database Consolidation Tool).
  • While all editions of SQL Server are supported, K2 recommends standard or better for production systems.
  • SQL Clustering is supported.
  • SQL AlwaysOn and SQL mirroring are supported for single database scenarios only.
  • SQL_Latin1_General_CP1_CI_AS collation or Latin1_General_CI_AS collation is required on the SQL Server instance. If your K2 database collation does not match your SQL instance collation, you need to install K2 Five Fix Pack 7 or later, or K2 4.7 November 2017 Cumulative Update Fix Pack 10 or later (depending on your version of K2) after installing/upgrading K2, to address a potential runtime error.
  • For information on what versions of SQL Server can be integrated with SmartObjects using the SQL Server service broker, see the SQL Server section.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
Azure SQL Database
More...
Check Check Check Check Check Check
  • Installation on Azure SQL is supported for Azure Single Database DTU model size S2 or greater (size P1 is recommended, however this may vary depending on the use of K2 in your environment).
  • Installation is not supported for Single Database DTU model size S1 or lower, Single Database vCore model, Elastic Pool (any model) or Managed Instance (any model). Azure SQL deployments or subscription options not explicitly listed may not be supported.
  • See Installing the K2 Database in Microsoft Azure SQL for additional information on planning your Azure SQL integration.
SQL Server 2019 Check Check
SQL Server 2017 Check Check Check Check Check
SQL Server 2016 Check Check Check Check Check Check
SQL Server 2014 Check Check Check Check Check
SQL Server 2012 Check
Microsoft SQL Server Reporting Services (SSRS)
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • The K2 for Reporting Services component is an optional component that is installed on a Microsoft SSRS server.
  • If the K2 for Reporting Services component is installed for K2 4.7 or earlier, K2 leverages SSRS to run the standard K2 Workspace reports. See the Installing K2 for Reporting Services in a Distributed Environment for more information on installing this component.
  • To install K2 for Reporting Services on a reporting services server, reporting services should be running in Native Mode (not SharePoint Integrated Mode).
  • Installing the K2 provider in SSRS requires SQL Standard Edition or higher. SSRS in SQL Express Edition does not allow installing of third-party providers. See the Microsoft article: SQL Server Reporting Services features supported by its editions for more information.
  • See the K2 4.7 Software Requirements and Prerequisites product documentation for additional information on K2 for Reporting Services (server) components and recommendations.
  • K2 Five introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: K2 Five and Supported Technologies for more information.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
SQL Server 2016 Check
SQL Server 2014 Check
SQL Server 2012 Check
Microsoft SharePoint
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • This section lists the versions of Microsoft SharePoint where you can install the K2 for SharePoint app, K2 for SharePoint 2010 component, and the K2 for SharePoint 2013 component in SharePoint 2010 mode.
  • If installing K2 Five, the K2 for SharePoint App will be deployed to the SharePoint App Catalog as part of the installation wizard. Once the app is added to the app catalog, you will add the app to your SharePoint environment.
  • If you are using K2 Cloud, you will receive instructions from K2 on obtaining and installing the K2 for SharePoint app. Once the app is added to the app catalog, you will add the app to your SharePoint environment.
  • You should no longer use the K2 for SharePoint app provided in the Microsoft App Store.
  • See K2 for SharePoint Installation for more information about installing K2 for SharePoint in K2 Five.
  • K2 4.7 introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: Third-party support with the K2 4.7 release for more information.
  • K2 Five introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: K2 Five and Supported Technologies for more information.
  • You cannot upgrade to K2 Five if your K2 blackpearl 4.7 or earlier environment has the K2 for SharePoint 2010 or the K2 for SharePoint 2013 in 2010 mode components installed. You must uninstall these deprecated components before you can upgrade to K2 Five.
  • The K2 for SharePoint App and K2 for SharePoint 2013 brokers allow K2 to interact with SharePoint 2013 and later via CSOM (Client Side Object Model) and REST. The K2 for SharePoint App allows K2 to interact with SharePoint Online.
  • The K2 for SharePoint 2010 components and SharePoint 2010 service brokers allow K2 4.7 and earlier to interact with SharePoint 2010, and SharePoint 2013 sites in SharePoint 2010 mode.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
SharePoint Online
More...
Check Check Check Check Check Check
  • Standard and Enterprise.
  • Sites that were originally created in BPOS-S and later migrated to SharePoint Online do not support the SharePoint App model and therefore are not supported by K2.
  • The O365 editions supported include Business Essentials, Premium; Enterprise E1 or greater; Education E1 or greater; Government E1 or greater; SharePoint Online Standalone Plan 1 or greater.
  • When applied to SharePoint Online environments, the K2 for SharePoint App is only supported in regions and deployments managed directly by Microsoft and use the https://login.windows.net Azure Active Directory authentication mechanism. For example, K2 does not support SharePoint Online environments in China, Germany, or US Government.
SharePoint 2019 (On-Prem) Check Check
SharePoint 2016 (On-Prem)
More...
Check Check Check Check Check Check
  • To install K2 for SharePoint, the July 2016 Cumulative Update (or later) for SharePoint is required.
SharePoint 2013
More...
Check Check Check Check Check Check
  • Standard and Enterprise.
SharePoint 2010
More...
Check
  • Foundation, Standard, Enterprise.
  • See K2 for SharePoint 2010 Installation for more information on installing K2 for SharePoint 2010 in a K2 4.7 environment when integrating with SharePoint 2010.
  • See SharePoint Online/2013/2016 for more information on installing K2 for SharePoint in a K2 4.7 environment when integrating with SharePoint Online/2013/2016.
  • Publishing and Records Management integration requires MOSS Standard or MOSS Enterprise.
Microsoft Visual Studio
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • This section lists the versions of Microsoft Visual Studio where you can install K2 for Visual Studio components (for example, K2 Projects, K2 workflows, K2 SmartObjects, and K2 Process Management).
  • See the user guide topic: Create with K2 for Visual Studio for more information.
  • K2 4.7 introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: Third-party support with the K2 4.7 release for more information.
  • K2 Five introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: K2 Five and Supported Technologies for more information.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
Visual Studio 2015
More...
Check Check Check Check Check Check
  • Professional, Enterprise
Visual Studio 2013
More...
Check Check Check Check Check Check
  • Premium, Ultimate, Professional
.NET Framework
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • K2 requires the latest .NET 3 series AND .NET 4 series frameworks to function. You must have .NET 3.5 and .NET 4.6.1 installed to install or upgrade to K2 4.7 or K2 Five.
  • As of K2 Five 5.3, .NET Core 2.1.7 is required to install or upgrade K2.
  • Microsoft requires customers to be on certain versions of client operating systems, browsers, or .NET frameworks based on their new lifecycle policies: Lifecycle FAQ - .NET Framework.
  • Other .NET framework versions may be installed as necessary for other product requirements apart from K2, such as Microsoft SharePoint or Microsoft Visual Studio that may require their own specific versions of the .NET framework.
  • K2 supports the .NET 4.6 series framework that has a runtime version of v4.0, as defined by the Microsoft supported runtime element statement. For example, .NET 4.5, 4.6, 4.6.1, 4.6.2 and 4.7 are all considered v4.0 runtime versions and are all supported.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
.NET Framework 4.8
More...
Check Check Check Check See support notes See support notes
.NET Framework 4.7.2
More...
Check Check Check Check See support notes See support notes
.NET Framework 4.7.1
More...
Check Check Check Check See support notes See support notes
  • K2 Five 5.1 and later versions support .NET 4.7.1 and do not need additional fix packs installed to add support for .NET 4.7.1. Earlier versions of K2 Five (such as RTM) and K2 blackpearl 4.7 might require installation of a fix pack to support .NET 4.7.1. See the KB article Known Issue: Upgrading to .NET Framework 4.7.1 incompatible with K2 for information on fix pack requirements for supporting .NET 4.7.1.
.NET Framework 4.7 Check Check Check Check Check Check
.NET Framework 4.6.2 Check Check Check Check Check Check
.NET Framework 4.6.1 Check Check Check Check Check Check
.NET Framework 3.5 Check Check Check Check Check Check
Microsoft Management Console MMC
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • This prerequisite is not required if you are not using, or do not intend to use, the thick client package and deployment tool. The web-based package and deployment tool does not require Microsoft Management Console.
MMC 3.0
More...
Check Check Check Check Check
  • Required for the K2 Package and Deployment component (P&D).
Microsoft PowerShell
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • This prerequisite is required for the K2 Package and Deployment component for scripted deployments, K2 Server, and the K2 for SharePoint installer.
PowerShell 5.0 Check Check Check Check Check Check
PowerShell 4.0 Check Check Check Check Check Check
PowerShell 3.0
More...
Check Check Check Check Check Check
  • K2 Package and Deployment (RTM).
Mobile Apps Operating Systems
More...
K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • This section lists the supported mobile operating systems for installing K2 mobile applications.
  • For information on mobile web browser support, see the Mobile Browsers section.
  • Later versions of K2 mobile applications may support newer versions of mobile operating systems than the versions listed below. Refer to the K2 Product Support and Release Strategy for more information on K2’s support strategy for mobile operating systems. See the appropriate mobile application release notes for updated support and compatibility information.
  • Product documentation for the mobile applications: K2 Mobile Applications.
K2 Workspace for iOS: iOS 13 or later
More...
Check Check Check Check Check
K2 Mobile for iOS: iOS 10 or later
More...
Check
K2 Workspace for Android: Android 5 or later
More...
Check Check Check Check Check
K2 Mobile for Android: Android 4.1 or later
More...
Check
Authentication (Identity Providers) Compatibility
This section lists which user identity providers can be used for inbound authentication with K2. For more on authentication in K2, see Authentication and Authorization in K2. K2 uses a concept called "user managers" to interact with identity providers; for more information on user managers in K2, see Introduction to User Managers in the installation and configuration guide. K2 Nexus Platform uses OpenID Connect and can integrate with SCIM 2.0 identity providers for inbound authentication. If you have a SCIM 2.0-compliant and OpenID Connect-capable identity provider and do not see it listed in the supported identity providers below, please contact your K2 representative to have your identity provider assessed for future support.
Uncheck the K2 product versions you do not want displayed. Check the K2 product versions you want displayed.
Supported Products Support Ended Products
K2 Nexus Platform K2 Five (5.1)
K2 Cloud K2 Five (5.0)
K2 Platform Classic (5.4) 4.7
K2 Five (5.3)
K2 Five (5.2)
Authentication Provider Compatibility Matrix
spacer
Identity Provider K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
Azure Active Directory (AAD)
More...
Check Check Check Check Check Check Check Check
  • K2 Cloud subscriptions require AAD and it is the only supported authentication mechanism for K2 cloud environments. You must have an AAD tenant before a K2 Cloud environment can be provisioned.
  • K2 Nexus Platform subscriptions can leverage AAD or another supported Identity Provider (see details for other supported Identity Providers below).
  • Using AAD for authentication with K2 Cloud or K2 Five requires installation of the Azure Active Directory for K2 or K2 for Office 365 App. See the user guide topic Applications for more information.
  • Using AAD for authentication with K2 Nexus Platform requires installation of the Azure Active Directory for K2 or K2 for Office 365 App.
  • Active Directory Federation Services (ADFS) is supported with AAD when ADFS is configured as described in the Microsoft article Azure AD Connect and federation. See Active Directory Federated Services (ADFS) for more information. ADFS enables using other identity providers (for example, Okta and Ping), if user UPNs from the identity provider are present in AAD via Azure AD connect. See the knowledge base article How To: Configure Okta to Log In to K2 Sites for an example.
  • K2 Cloud and K2 Five uses the Microsoft Windows Identity Foundation which means that only relying party trusts configured for the WS-FED protocol that issue SAML 1.1 or SAML 2.0 tokens are supported.
Active Directory (AD)
More...
Check Check Check Check Check Check
K2 SQL User Manager (SQLUM)
More...
Check Check Check Check Check Check
Google Cloud Identity
More...
Check
Product Integration Compatibility
This section describes products and versions of products that K2 can integrate with, through Service Brokers, Workflow Wizards or other integration mechanisms.
Uncheck the K2 product versions you do not want displayed. Check the K2 product versions you want displayed.
Supported Products Support Ended Products
K2 Nexus Platform K2 Five (5.1)
K2 Cloud K2 Five (5.0)
K2 Platform Classic (5.4) 4.7
K2 Five (5.3)
K2 Five (5.2)
Microsoft Product Integration
spacer
This section describes what versions of Microsoft products K2 can integrate with, usually via SmartObjects and/or workflow wizards. For information on support policies for Microsoft product updates and service packs, refer to the K2 technical bulletin Microsoft and third-party support.
Microsoft SharePoint
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • The K2 for SharePoint App and K2 for SharePoint 2013 brokers allow K2 to interact with SharePoint 2013 and later via CSOM (Client Side Object Model) and REST. The K2 for SharePoint App allows K2 to interact with SharePoint Online.
  • The K2 for SharePoint 2010 components and SharePoint 2010 service brokers allow K2 4.7 and earlier to interact with SharePoint 2010, and SharePoint 2013 sites in SharePoint 2010 mode.
  • See K2 for SharePoint in the K2 Five user guide topic for more information about creating, administering and using applications with K2 for SharePoint.
  • K2 4.7 introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: Third-party support with the K2 4.7 release for more information.
  • K2 4.7 introduced new and changed support for integration with Microsoft SharePoint. See the K2 4.7 and SharePoint Integration Options for more information and options for customers to remain supported with their K2 solutions that integrate with SharePoint.
  • K2 Five introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: K2 Five and Supported Technologies for more information.
  • K2's support for SharePoint cumulative updates is described in K2 Product Support and Release Strategy.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
SharePoint Online
More...
Check Check Check Check Check Check Check Check
  • Standard and Enterprise.
  • Sites that were originally created in BPOS-S that were later migrated to SharePoint Online do not support the SharePoint App model and therefore are not supported by K2.
  • The O365 editions supported include Business Essentials, Premium; Enterprise E1 or greater; Education E1 or greater; Government E1 or greater; SharePoint Online Standalone Plan 1 or greater.
SharePoint 2019 (On-Prem) Check Check
SharePoint 2016 (On-Prem)
More...
Check Check Check Check Check Check
  • Standard and Enterprise.
  • Integration with SharePoint 2016 requires the SharePoint 2016 April 2018 update.
SharePoint 2013
More...
Check Check Check Check Check Check
SharePoint 2010
More...
See support notes
Microsoft SQL Server
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • Use the SQL Server service broker to integrate with Microsoft SQL Server databases by exposing tables, stored procedures and views as service objects and SmartObjects. The available methods depend on the type of SQL entity being exposed.
  • Service instances are configured per database.
  • While all editions of SQL Server are supported, K2 recommends standard or better for production systems.
  • See SQL Server Service for more information.
  • For information on what versions of SQL Server are supported for installation of the K2 database, see the SQL Server section.
  • K2 4.7 introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: Third-party support with the K2 4.7 release for more information.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
Azure SQL Database
More...
Check Check Check Check Check Check Check Check
SQL Server 2019 Check Check Check Check
SQL Server 2017 Check Check Check Check Check Check Check
SQL Server 2016 Check Check Check Check Check Check Check Check
SQL Server 2014 Check Check Check Check Check Check
SQL Server 2012 Check
Microsoft SQL Server Reporting Services (SSRS)
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • Use the SQL Reporting Service service type to integrate with Microsoft SSRS and expose export methods for SSRS reports as SmartObject methods. See SQL Reporting Services product documentation for more information.
  • The Microsoft Report Viewer Redistributable 2005 must be installed on the K2 application server before registering a new service instance of this service type.
SQL Server 2016 Check
SQL Server 2014 Check
SQL Server 2012 Check
Microsoft Exchange Server
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • K2 Cloud and K2 Five (5.1 and later) feature a new Exchange service type for integration between K2 and Microsoft Exchange through SmartObjects. See the Exchange Online Feature Activation for more information on using this new service type.
  • In K2 Five, the Exchange Administration service broker can be used to work with mailboxes in Exchange, such as enabling or disabling mailboxes.
  • In K2 Five, the Exchange Management service broker can be used to interact with Exchange tasks, calendars, and meetings.
  • For a comparison between functionality of the new Exchange service type and previous Exchange service types, see the KB article Comparison of the Exchange Service Brokers.
  • K2 4.7 introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: Third-party support with the K2 4.7 release for more information.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
Exchange Online Check Check Check Check Check Check Check Check
Exchange 2019 Check Check Check Check
Exchange 2016 Check Check Check Check Check Check Check Check
Exchange 2013 Check Check Check Check
Microsoft Dynamics CRM
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • This section lists the versions of Microsoft CRM that K2 can integrate with via SmartObjects and workflow wizards.
  • The CRM Functions and Entities service instances provide K2 with the ability to interface with CRM functions and entities based on a Dynamics CRM 2011, 2013, or 2015 server.
  • The CRM Wizards allow certain actions to be automatically performed during a workflow.
  • K2 4.7 introduced changes regarding support for certain versions of third-party software products. See the technical bulletin: Third-party support with the K2 4.7 release for more information.
  • This matrix does not explicitly distinguish between RTM, Service Packs (SP), Cumulative Updates (CU), or update rollups of third-party software. Specific considerations regarding SP/CU/etc. support is noted in the ‘More…’ notes for a component or version. Refer to the Product Support Policy for more information on K2’s support policy for SPs, CUs, or other third-party software updates.
CRM Online
More...
Check Check Check Check Check Check Check Check
  • Also known as Dynamics 365 for Customer Service.
  • When configuring CRM integration with CRM Online, you must use the Discovery Service URL instead of the Organization Service URL. See Configuring a CRM Service Instance for CRM Online for complete details.
CRM 2016 Check Check Check Check Check Check Check Check
CRM Online 2015
More...
Check Check Check Check Check Check Check Check
CRM 2015 Check Check Check Check Check Check Check Check
CRM 2013
More...
Check Check Check Check Check Check Check Check
  • Includes support for Update Rollup 1.
Microsoft Power Automate
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
Microsoft Power Automate Check Check Check Check Check Check Check
Microsoft Teams K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
Microsoft Teams
More...
Check
Other Product Integration
spacer
This section lists other third-party software that K2 can integrate with, usually through SmartObjects and/or workflow wizards. For information on support policies for third-party products, refer to the K2 technical bulletin on product support, Microsoft and third-party support.
K2 connect for SAP K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
K2 connect
More...
Star Star Check Check Check Check Check Check
Oracle
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • Oracle integration is supported through the use of the Oracle service broker.
  • You cannot install K2 databases on any DBMS other than Microsoft SQL Server, as listed in the SQL Server section.
  • K2 uses the ODP.NET data connector. Refer to the Oracle Service documentation for additional information.
Oracle 19c
More...
Check Check Check Check        
  • Enterprise/Standard Editions
Oracle 18c
More...
Check Check Check Check  
  • Enterprise/Standard Editions
Oracle 12c (Release 2)
More...
Check Check Check Check  
  • Enterprise/Standard Editions
Oracle 12c (Release 1) Check Check Check Check Check Check Check Check
Oracle 11g (Release 2) Check Check Check Check Check Check Check Check
Oracle 11g (Release 1) Check Check Check Check Check Check Check Check
DocuSign
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • The DocuSign service broker and wizards enable integration with the DocuSign e-signature solution.
  • Theoretical and functional knowledge of DocuSign is required to use the DocuSign integration provided by K2. You may learn more about DocuSign from the DocuSign website.
  • The API version listed is what was tested against during the release cycle. See the third-party integration support plan for additional information.
DocuSign Enterprise REST API v2 Check Check Check Check Check Check Check Check
Salesforce
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • K2 Cloud and K2 Five (5.1 and later) feature a new Salesforce service type that utilizes Salesforce’s REST APIs for integration between K2 and Salesforce through SmartObjects. See the Salesforce product documentation for more information.
  • K2 Five environments also contain the Salesforce legacy service type which uses the legacy Salesforce SOAP API for integration. See Salesforce (Legacy) Service documentation for information on using the legacy Salesforce service broker and associated workflow wizards.
Salesforce Check Check Check Check Check Check Check Check
Cloud Storage Providers
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • Use Cloud storage providers to store and retrieve files through SmartObjects.
  • *As of 1 July 2020, Cloud Storage features (i.e. Box, DropBox, Google Drive, and OneDrive) are no longer available for new activations. If you had previously activated Cloud Storage features in your K2 environment, those features are still supported and available for use; however, you will not be able to request new feature activations for any of the Cloud Storage features. Existing activations of Cloud Storage features will be deactivated on 31 December 2020.
Box
More...
  See Cloud Storage Providers notes
DropBox
More...
  See Cloud Storage Providers notes
Google Drive
More...
  See Cloud Storage Providers notes
Microsoft OneDrive
More...
  See Cloud Storage Providers notes
RPA Providers
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • Integrate K2 with Robotic Process Automation (RPA) providers.
UiPath
More...
Check Check Check Check Check Check Check
Blue Prism
More...
Check Check Check Check Check Check Check
Generic Brokers
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
Javascript Service Provider (JSSP)
More...
Check
REST
More...
Check Check Check Check Check Check Check Check
OData
More...
Check Check Check Check Check Check Check Check
Web Services
More...
Check Check Check Check Check Check Check Check
WCF Services
More...
Check Check Check Check Check Check Check Check
.NET Assemblies
More...
Check Check Check Check Check Check
Browser Compatibility
This section lists the web browsers tested against the following use cases:
  • Design-time: Designing artifacts using the available K2 browser-based design tools, which include the design tools available in the K2 Designer site.
  • Runtime and Mobile: Using K2 websites (for example, the K2 Management site and K2 Workspace) worklists and SmartForms.
Uncheck the K2 product versions you do not want displayed. Check the K2 product versions you want displayed.
Supported Products Support Ended Products
K2 Nexus Platform K2 Five (5.1)
K2 Cloud K2 Five (5.0)
K2 Platform Classic (5.4) 4.7
K2 Five (5.3)
K2 Five (5.2)
Browser Compatibility
spacer
Design-time
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • Design-time refers to using the available K2 browser-based design tools to build workflows, SmartObjects, SmartForms, and other K2 artifacts. These actions are performed by application builders. This table lists the web browsers that have been tested against the design-time usage of K2.
  • Microsoft ended support for IE 8 through 10 on 12 January 2016. See the K2 technical bulletin on Internet Explorer for more details on what this means for K2 support. Microsoft requires customers to be on certain versions of client operating systems, browsers, or .NET frameworks based on their new lifecycle policies. See Microsoft Internet Explorer Support Lifecycle Policy FAQ for more information.
  • It is not recommended to use private browsing modes (for example, Incognito, Private, InPrivate) when working with K2 at design-time. Doing so might result in unexpected behavior, which may include data loss.
Edge Check Check Check Check Check Check Check
Internet Explorer (11) Check Check Check Check Check Check Check Check
Chrome
More...
Check Check Check Check Check Check Check Check
  • Tested on version: 58.0.3029.96.
  • Applies to Chrome for Mac and Chrome for Windows.
Firefox
More...
Check
  • Tested on version: 48.0.2.
Safari (MacOS)
More...
Check
  • Tested on version: 9.1.2.
Silverlight
More...
Check Star Check Legacy Legacy Legacy Legacy Legacy
  • Silverlight is required when designing workflows and SmartObject associations using the legacy browser-based design tools. This applies to K2 versions 4.7 and earlier, or K2 Five, upgraded from K2 4.7.
Runtime
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • Runtime refers to using web browsers to interact with K2 artifacts (for example, SmartForms) or administering K2 through the available web-based administration tools. These actions are performed by end users and system administrators. This table lists the web browsers that have been tested against the runtime use of K2.
  • The legacy K2 Workspace component is compatible with Internet Explorer, and it may not render or behave as expected in other web browsers. In addition, if you are using Internet Explorer 11, you must run IE in compatibility mode. See the knowledge base article Internet Explorer 11 workaround to allow K2 Workspace and K2 Process Portals to render correctly for more information.
  • Microsoft ended support for IE 8 through 10 on 12 January 2016. See the K2 technical bulletin on Internet Explorer for more details on what this means for K2 support. Microsoft requires customers to be on certain versions of client operating systems, browsers, or .NET frameworks based on their new lifecycle policies. See Microsoft Internet Explorer Support Lifecycle Policy FAQ for more information.
  • Some browsers' security or configuration settings (such as, but not limited to, script origin policies or JavaScript restrictions) might prevent certain features from working as expected.
Edge Check Check Check Check Check
Internet Explorer (11) Check Check Check Check Check Check Check Check
Chrome
More...
Check Check Check Check Check Check Check Check
  • Tested on version: 58.0.3029.96.
Firefox
More...
Check Check Check Check Check Check Check Check
  • Tested on version: 48.0.2.
Safari (MacOS)
More...
Check Check Check Check Check Check Check Check
  • Tested on version: 9.1.2.
Silverlight
More...
Check Legacy Check Legacy Legacy Legacy Legacy Check
  • Silverlight is required when designing workflows and SmartObject associations using the legacy browser-based design tools. This applies to K2 versions 4.7 and earlier, or K2 Five, upgraded from K2 4.7.
Mobile Browsers
More...
K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
  • K2 tests runtime interaction with K2 artifacts on a variety of mobile browsers as listed in the table below. Note that only runtime usage (for example, interacting with SmartForms) is supported on mobile devices. No design time usage is supported for mobile devices.
  • Learn more about K2 Mobile applications at help.k2.com/mobile.
iOS (Safari Browser)
More...
Check Check Check Check Check Check Check Check
  • Includes iPhones and iPads with iOS 8 or later.
Windows Devices (Native Browser) Check Check Check Check Check Check Check Check
Android (Native Browser)
More...
Check Check Check Check Check Check Check Check
  • Android version 4.2.2 or later (Jellybean).
K2 Language Pack
The K2 Language Pack is an add-on component that enables cultural adaptation and translation of non-configurable runtime UI elements. The K2 Language Pack supports different languages for the following items: Standard SmartForms controls, the SmartForms Control Pack controls, the View Flow report, and elements of the K2 Designer.
Uncheck the K2 product versions you do not want displayed. Check the K2 product versions you want displayed.
Supported Products Support Ended Products
K2 Nexus Platform K2 Five (5.1)
K2 Cloud K2 Five (5.0)
K2 Platform Classic (5.4) 4.7
K2 Five (5.3)
K2 Five (5.2)
K2 Language Pack
spacer
spacer K2 Nexus Platform K2 Cloud K2 Platform Classic (5.4) K2 Five (5.3) K2 Five (5.2) K2 Five (5.1) K2 Five (5.0) 4.7
German         Check Check
French         Check Check
Simplified Chinese         Check Check
Traditional Chinese         Check Check
Afrikaans         Check Check
Spanish         Check Check
Portuguese         Check Check
Italian         Check Check
Hebrew         Check Check
Czech         Check Check
Japanese         Check Check
Slovak         Check Check
Mobile Apps Languages
spacer
Android and iOS (only) Android iOS
English Check Check
German Check Check
French Check Check
Simplified Chinese Check Check
Traditional Chinese Check Check
Croatian Check Check
Spanish Check Check
Russian Check Check
Czech Check Check
Japanese Check Check
Slovak Check Check
Additional Resources
Additional resources that may help you learn more about the capabilities of the K2 platform and be notified of new releases.
Downloads, Help, News and Announcements
spacer
K2 Software Downloads
  • To download K2 software, access the K2 Partner and Customer Portal, then click the Downloads menu item in the navigation bar.
  • You must have a partner or customer account to access the portal. Contact your K2 account representative to obtain a login account.
K2 Knowledge Center
News and Announcements
  • Browse to the News and Announcements list to stay up-to-date with new product, content, and other announcements from K2.
K2 Community
  • Find community forums and tools developed by people using K2 at the K2 Community site.