LEGACY CONTENT
This article refers to legacy products, components or features. Therefore, the content in this article is offered "as is" and will no longer be updated. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Introduction

When building a K2 process in K2 blackpearl 0807 the SharePoint Events Process wizard will not accept a valid SharePoint URL and the user is prompted to specify the SharePoint site URL even though it was already correctly filled in with the value stored in the Environment Library for the SharePoint service. The result is an error and the wizard configuration cannot be completed. The error is caused by the IPv6 TCP protocol being set to enabled. "Windows Vista" or "Windows Server 2008" as a client or server uses the "new" IPv6 TCP protocol as its default networking protocol forcing the validation calls testing for MOSS server status and port availability to supply IPv6 protocols as the communication layer.

The local machine has the following items installed:

  • K2 blackpearl 0807 4.8210.1.x or 4.8210.2.0

Example Scenario
Note: The steps below describe one scenario under which this error may occur. The steps below are simplified and not all the steps will be shown or described.

The K2 developer performs the following steps within a K2 process designer canvas:
  1. Create a new K2 project
  2. Drag and drop the SharePoint Events Process wizard onto the design canvas
  3. Select "Events for List and Library Items"
  4. Click "Browse" to specify the Document Library to monitor
  5. Drag the SharePoint Server node from the Environment Library onto the SharePoint Site URL field on the Connection Settings screen.
  6. The SharePoint Design Time Values dialog will open, add the same SharePoint site URL as specified in the Environment Library
  7. Click OK
  8. An error occurs stating "This protocol version is not supported."

Error Messages

  • "This protocol version is not supported."

Error Resolution

This Patch is contained within the latest K2 blackpearl 0807 Update. Install the update package to resolve the error.

The latest K2 blackpearl 0807 Update is available as an independent installation package which can be found here: https://portal.k2.com/downloads/bp/default.aspx.