LEGACY CONTENT
This article refers to legacy products, components or features. Therefore, the content in this article is offered "as is" and will no longer be updated. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Introduction

After installing K2 blackpearl 0807 (4.8210.2.450) KB000450 into an existing K2 blackpearl 0807 environment and then trying to uninstall K2 blackpearl, the application will show an incompatible version message. This message prevents the completion of the uninstall process.

Error Scenario Steps

Note: The steps below describe one scenario under which this error may occur. The steps below are simplified and not all the steps will be shown or described.
  1. Apply K2 blackpearl 0807 (4.8210.2.450) KB000450 to an existing K2 blackpearl 0807 (4.8210.2.370) environment
  2. Open Add remove programs
  3. Select K2 blackpearl 0807 (4.8210.2.0)
  4. Click on Uninstall
  5. The 'Products installed' error message will appear

Error Messages

The following error message applies to this article:

  • K2 blackpearl 0807 (4.8210.3.0) cannot be used to upgrade an existing K2 blackpearl 0807 installation. Please use K2 blackpearl 0807 Update (4.8210.2.450) KB000450 to update your environment.

Error Resolution

This Hotfix is contained within the latest K2 blackpearl 0807 Update. Install the update package to resolve the error.

The latest K2 blackpearl 0807 Update is available as an independent installation package which can be found here: https://portal.k2.com/downloads/bp/default.aspx