LEGACY CONTENT
This article refers to legacy products, components or features. Therefore, the content in this article is offered "as is" and will no longer be updated. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Introduction

When assigning a group to a role in K2 Management Console > Administration > Roles, the group is added as a ‘User’ instead of a ‘Group’. Therefore, the role never gets resolved to users in the group and the users in the group never get the items assigned to the role.

Error Scenario

Note: The circumstances described in this article are one scenario under which this issue may, or is known to occur. The description is intended to be specific to the scenario described and does not take into account all possible scenarios or circumstances.
  1. Create an Active Directory group with users.
  2. Create a role containing the Active Directory group.
  3. The K2 Management Console > Administration > Roles page in SharePoint displays the group as Type ‘User’.

Error Message

There is no error message. Note that the group name displays under the Type ‘User’ column:

Error Resolution

Note: After applying this Hotfix the Group needs to be deleted and added again to the Role (SharePoint > K2 Management Console > Administration > Roles > Add Role).

This Hotfix is contained within the latest K2 blackpoint 0902 Update. Install the update package to resolve the error.

The latest K2 blackpoint 0902 Update is available as an independent installation package which can be found here: http:// portal.k2.com /downloads/bp/default.aspx