Introduction

After successfully running the K2 Setup Manager to update the configuration errors were found with InfoPath and K2 Workspace.

Error Scenario

This issue occurred when an upgrade was done from a previous version. During the upgrade the default site, K2 Workspace and runtime services security settings where changed and this resulted in the useAppPoolCredentials property being changed incorrectly from True to False in the web.config and/or the applicationHost.config files.

Error Messages

There are no specific error messages. See the behavior description above.

Error Resolution

The security related values will no longer form part of the process when performing an upgrade and they will remain untouched.

The error has been resolved. This Hotfix is contained within the latest K2 Update. Install the update package to resolve the error.