Introduction

If a process with a configured escalation was designed using K2 Designer for SharePoint with Update KB001200, and the system was later upgraded to K2 4.5 Update KB001230, then the process could not be opened by K2 Designer for SharePoint.

Error Scenario

Processes that were written using K2 Designer for SharePoint with Update KB001200 were forward compatible with K2 Designer for SharePoint with Update KB001230 provided that there were no escalations. However, the presence of the escalation identified an error where the K2 Designer for SharePoint with Update KB001200 Escalation feature was not forward compatible with K2 Designer for SharePoint with Update KB001230.

This resulted in the designer being unable to open the process.

Reproduction Steps

  • Use an installation that has K2 Designer for SharePoint with Update KB001200 installed
  • Create a process with an escalation
  • Save the process
  • Upgrade the system to K2 Designer for SharePoint with Update KB001230
  • Once the system is upgraded, attempt to open the process

Runtime Considerations

The following considerations apply once the update has been installed.
The system will interrogate the process when the process is loaded to determine if the process is not backwards compatible. The process XML will only be upgraded if the process is not backwards compatible i.e. it was written using K2 Designer for SharePoint with Update KB001200 and it contains ONE or more escalations. To ensure that the changes are implemented, SAVE the process to the server.

Error Resolution

The above item has been resolved and can be corrected by installing the latest Update package