Issue:

After upgrading to K2 smartforms 1.0.6 and logging on to the K2 Designer, a “Keyset does not exist” error may occur, as shown below:

Image

Cause

This error may occur after upgrading or installing a clustered K2 Workspace environment, where there are multiple K2 Workspace servers. Certificates are created on the first node for the STS Authentication, and inserted into two places:

  • The K2 database,
  • The local Computer Certificate Store.

When the rest of the K2 Workspace Servers are upgraded / installed into the current clustered environment, the certificate is read from the K2 database and added to the local computer. During this process, occasionally not all of the certificate’s details are available, and a certificate is added to the store that cannot be read and decrypted.

Workaround 1:

  1. Perform an IISRESET.

If this does not solve the issue, then attempt to fix the certificates using the Microsoft Management Console as shown in Workaround 2.

Workaround 2:

  1. Start the Microsoft Management Console (Run> MMC).
  2. Add snap in Certificates for the local machine Computer account.
  3. Browse to the personal store and search for the certificate with the friendly name “K2 Self Signed”.
  4. Right click on all of those certificates and choose Manage Private Keys from the popup menu.
  5. Click OK (there is no need to change anything; they just need to be opened).
  6. Restart the K2 Server.
  7. Perform an IISRESET.

If this still does not solve the issue, then attempt to fix the certificates using the Microsoft Management Console and the attached application as shown in Workaround 3.

Workaround 3:

  1. Start the Microsoft Management Console (Run> MMC).
  2. Add snap in Certificates for the local machine Computer account.
  3. Browse to the personal store and search for the certificate with the friendly name “K2 Self Signed”.
  4. Right click on all of those certificates and choose Manage Private Keys from the popup menu.
    1. If an ‘Object Not Found’ error is thrown, run the attached application and follow the prompts.
    2. Restart the K2 Servers
    3. Perform an IISRESET on the local Workspace Server