Introduction

In this scheduled release, we've updated K2 components with new and improved functionality and important bug fixes. The K2 4.6.10 release consists of the following updated components:

  • K2 blackpearl 4.6.10  (4.12060.1690.2)
  • K2 smartforms 4.6.10 (4.12165.1700.2)
  • K2 smartforms Control Pack 4.6.10 (4.13180.1710.2)
  • K2 for SharePoint 4.6.10 (4.13350.1720.2)
  • K2 Language Pack 4.6.10 (Preview) (4.13500.0.1)

Downloads

The various K2 4.6.10 installers can be downloaded from the  K2 Partner and Customer Portal. Use the table below to determine which installer you need.

K2 4.6.10
Current Version K2 Installation Package K2 Update K2 blackpearl K2 smartforms K2 Control Pack K2 for SharePoint (2013) K2 Language Pack (Preview)
No K2

 check

Optional
K2 4.6.9 (Any of the following components: blackpearl, smartforms, smartforms Control Pack, K2 for SharePoint)

 check

Optional
K2 4.6.8 or earlier (blackpearl, smartforms, smartforms Control Pack, K2 for SharePoint)

 check

K2 blackpearl 4.6.8 or earlier

 check

K2 blackpearl and Smartforms 4.6.8 or earlier

 check

 check

Optional
The black selection check above suggests the recommended installer for each scenario.
Note: The K2 4.6.10 update includes the hotfixes included in previous K2 4.6 Updates, so there is no need to install the previous updates.

What’s New in this release

There are several new features and enhancements available in this release.

K2 blackpearl

K2 smartforms

K2 smartforms Control Pack

K2 for SharePoint

K2 Language Pack (Preview)

What’s been fixed in this release

K2 4.6.10 includes a number of bug fixes. Below is a list of the resolved issues by component. 

K2 blackpearl

K2 smartforms

K2 smartforms Control Pack

K2 for SharePoint

Known Issues

The following issues are currently known for K2 blackpearl and include workarounds where possible.

K2 blackpearl

K2 smartforms

K2 smartforms Control Pack

K2 for SharePoint

K2 Language Pack (Preview)

Important Considerations and Breaking Changes

K2 blackpearl

K2 smartforms

K2 for SharePoint

K2 Language Pack (Preview)

Installation

Refer to the Installation and Configuration guides available on help.k2.com for the prerequisites and steps needed to install the various components. Before installing any of the K2 4.6.10 components, ensure the correct prerequisite software has been installed in your environment.

When installing K2 4.6.10 using the full installation package the following install order is required.

  1. K2 blackpearl 4.6.10  (4.12060.1690.2)
  2. K2 smartforms 4.6.10 (4.12165.1700.2)
  3. K2 smartforms Control Pack 4.6.10 (4.13180.1710.2)
  4. K2 for SharePoint 4.6.10 (4.13350.1720.2)
  5. K2 Language Pack 4.6.10 (Preview) (4.13500.0.1)

Prerequisites:

See the K2 installation and configuration documentation for a full list of prerequisites. In this release the following prerequisites have been added or changed:

  • PowerShell 3 or greater is required.
  • SharePoint Online Management Shell (K2 will automatically install this for you when you run the K2 for SharePoint 2013 installer or the K2 Update Package).

Upgrades:

In this release K2 is introducing the K2 Update Package. This installer makes it easier and quicker to update your environment by adding new files and only updating files that have changed. The K2 Update Package updates all the K2 components (blackpearl, smartforms, Control pack, K2 for SharePoint) so you do not need to download and run multiple install files.

Refer to the table in the Download section or to the compatibility matrix to see if your current K2 version can be upgraded to K2 4.6.10.

The K2 Update Package automatically identifies what components are installed in your environment and will then update the components.

Note: If you are on a K2 version prior to K2 4.6.9 you must use the K2 Installation Package to upgrade your environment.

Update Step: Run the K2 Update Package on each machine (e.g. servers, web servers and client machines) where K2 components are installed. The K2 Server must be updated first, then update all the other servers in the environment. If K2 for SharePoint 2010 or K2 for SharePoint 2013 in 2010 mode is being used, the K2 for SharePoint Configuration wizard needs to be run. The Finish Panel will display the link to launch the K2 for SharePoint Configuration Wizard

For more information see the K2 Update Manager topic in the product documentation. 

Additional information:

  • If you are upgrading from a version prior to K2 4.6.9 and you use K2 for SharePoint 2010, you will need to run through the K2 for SharePoint Configuration Wizard. If K2 for SharePoint 2013 is being used, the K2 App will need to be re-deployed to the SharePoint App Catalog by running the Appdeployment.exe.
  • If your environment is using impersonation and Kerberos manual configuration is required when upgrading or setting up your environment. For more information see KB001607 – Delegation Settings to Allow Impersonation with Kerberos.
  • .NET 4.5 required by the K2 Setup Manager.
  • If you are currently on Windows Server 2008 R2 you will require Windows Server 2008 R2 Service Pack 1 when upgrading.
  • The K2 Server (Host Server) requires .NET Framework 4.5. Ensure that you have .NET 4.5 installed on the server before upgrading or installing.
  • PowerShell 3 or higher is required by the K2 Setup Manager.
  • Refer to the Important Considerations section above before installing or upgrading.
  • Ensure that you have the correct permissions to run the install to avoid installation issues. For the correct installation permissions refer to the installation and setup guides.