Package and Deployment Version Compatibility

LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Packages from different versions of K2 blackpearl and K2 Appit are backward-compatible with a few limitations, and a support policy and tool change will occur with releases going forward from the time of publication:

  • You cannot deploy a package created with K2 blackpearl to K2 Appit
  • With K2 blackpearl 4.7, you can deploy packages created with K2 blackpearl 4.6.10 or later
  • For releases after K2 blackpearl 4.7, you can only deploy a package created with the current release or one prior (N-1)
  • For K2 Appit 1.5, you can deploy packages created with any version of Appit
  • For releases after K2 Appit 1.5, you can only deploy packages that are less than 60 days old (creation date < 60 days)

See the attached package compatiblity matrix for more information.