Code Fix: Item References used in a workflow, go into error when opening Form Rules
KB001899
PRODUCT
Issue Description
Using an Item Reference or a secondary Item Reference from a control’s data source in a workflow event results in the mapping going into an error state when editing the form’s rules. Attempting to fix the reference by dragging the SmartObject from the control’s data source in the rule, and then finishing the Form, results in the rule being error badged.
Cause
The integration of the workflow with the form did not cater for second runs regarding secondary item references.
Resolution
- Ensure you have K2 4.7 installed.
- Download and install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal
- Get the K2 4.7 May 2017 Cumulative Update FP1 from Regional Support.
- Install the K2 4.7 May 2017 Cumulative Update FP1 to apply the fix.