Code Fix: Refreshing a User in K2 using a different case results in a duplicate entry being added to the database
KB001911
PRODUCT
Issue Description
When a user accesses K2 their user details are added to the database. Expiring the user and accessing K2 with the same user but using a different case value causes a duplicate entry in the database.
Cause
The Contains check on the Destination Queue collection was case sensitive and added an existing FQN with a different casing to the collection.
Resolution
- Ensure you have K2 4.7 installed.
- Download and Install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal.
- Get the K2 4.7 May 2017 Cumulative Update FP2 from Regional Support.
- Install the K2 4.7 May 2017 Cumulative Update FP2 to apply the fix.