Issue Description

When deploying a project in K2 Designer for Visual Studio, an “Obsolete Warning” message occurs multiple times.

Cause

The warning messages were related to the .NET Framework version used, mainly .NET 3.5.

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 May 2017 Cumulative Update FP10 from Regional Support.
  4. Install the K2 4.7 May 2017 Cumulative Update FP10 to apply the fix.
  5. Restart the server where Visual Studio is installed to clear MSBuild cache.