Known Issue: Error occurs when using a Date/Time field in a SharePoint Get List Item Reference wizard.

  • 16 February 2021
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Known Issue: Error occurs when using a Date/Time field in a SharePoint Get List Item Reference wizard

KB002071

PRODUCT
K2 blackpearl
K2 smartforms
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

When using a Date/Time field in the SharePoint Get List Item Reference wizard an “Object of type ‘System.Object[]’ cannot be converted to type ‘System.DateTime’.” occurs:

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Cause

The issue occurs when using a Date/Time field in a Get List Item Reference wizard from the Context Browser. The wizard uses the List method and returns multiple values. Reusing the field in a workflow as an input method, a single type value is used. Executing the SmartObject method, the results are returned, and the error occurs.

Resolution

To resolve the issue, when using the field as an input method in another workflow step, you can now specify returned items by selecting single or list for item references. Upgrade to the latest version of K2, which includes the fix.

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The fix has been implemented for K2 Designer thin client wizards.

 

 


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