Code Fix: Unable to assign the 'Managed By' user in a multiple domain environment

  • 16 February 2021
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Code Fix: Unable to assign the 'Managed By' user in a multiple domain environment

KB002088

PRODUCT
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

When attempting to assign a Managed By user to a user in a multiple domain environment, an error occurs. This occurs in the scenario where the K2 Server user is part of the first domain and the Managed By user is being assigned to a user in the second domain.

 

 

Error Message

The error message is similar to the following:

An Active Directory error has occurred.

Details:

LDAP Message LDAP_CONSTRAINT_VIOLATION

Description There was a constrain violation

 

 

Cause

When ManagedBy is being set in the code, it uses the Principal Domain Context of the K2 Server Service account and this prevented using the users from a different domain.

 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and install the K2 4.7 August 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 August 2017 Cumulative Update FP14 from Regional Support.
  4. Install the K2 4.7 August 2017 Cumulative Update FP14 to apply the fix.

 


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