Code Fix: Logging into K2 Designer using Forms STS authentication results in an error

  • 16 February 2021
  • 0 replies
  • 38 views

Badge +6
 

Code Fix: Logging into K2 Designer using Forms STS authentication results in an error

KB002150

PRODUCT
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

When logging into K2 Designer or any Runtime URL using Forms STS authentication, an error occurs.

Error Message

The error states: “An item with the same key has already been added”.

Cause

The error occurs while the security label methods are loaded. The current execution thread had not finished processing yet when the next thread tried to add the security method for a second time.

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and install the K2 4.7 November 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 November 2017 Cumulative Update FP6 from Regional Support.
  4. Install the K2 4.7 November 2017 Cumulative Update FP6 to apply the fix.

 


0 replies

Be the first to reply!

Reply