Issue Description

An error occurs when attempting to deploy a .NET Framework 4.7.1 based workflow using K2 Package and Deployment.

Error Message

The error message states: “The K2 Server must be configured for the .NET 4.7.1 runtime (or above) in order to deploy this process”.

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and Install the K2 4.7 March 2018 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 March 2018 Cumulative Update FP8 from Regional Support.
  4. Install the K2 4.7 March 2018 Cumulative Update FP8 to apply the fix.