Issue Description

When you try to deploy a .NET 4.7.1 K2 workflow with K2 Package and deployment you are presented with an error.

Error Message

The following error occurs: “The K2 Server must be configured for the .Net 4.7.1 runtime (or above) in order to deploy this process.”

Resolution

  1. Ensure you have K2 Five RTM installed.
  2. Get the K2 Five RTM FP23 from Regional Support.
  3. Close K2 Package and Deployment.
  4. Install the K2 Five RTM FP23 to apply the fix.
  5. The .NET 4.7.1 K2 workflow should now deploy.