Known Issue: Upgrading to K2 Five (5.1) or K2 Cloud (Update 4) moves deployed workflows to the root category

  • 16 February 2021
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Known Issue: Upgrading to K2 Five (5.1) or K2 Cloud (Update 4) moves deployed workflows to the root category

KB002418

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Download and extract this SQL script, and then run on your K2 database to move your deployed workflow definitions to the appropriate category. This script is only necessary if you have upgraded from K2 Five (5.0) to K2 Five (5.1) with either the .0 or .1 installer version.

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PRODUCT
K2 Cloud Update 4
K2 Five 5.1
BASED ON
K2 Cloud Update 4

 

Issue

When upgrading to K2 Five (5.1) or K2 Cloud Update 4, deployed workflows are moved from their existing category folders to the All Items folder (root category) in the category tree in K2 Designer.

Note that the design workflow object remains under the original folder and the deployed version of the same workflow displays under the root category. After applying the resolution in this article the workflow will display in the original category as shown in the Before Upgrade image below.

 

 

Before Upgrade:

Image

 

After Upgrade:

Image

 

 

Cause

This issue occurs due to a bug in the upgrade script, which causes deployed workflows to be moved to the root category in the category tree.

Resolution

To resolve the issue, download the MoveWorkflowsToTheirRelatedHTML5DefinitionCategory.zip script. Make a backup of the K2 database, and then run the script. The SQL script will move the workflows back to their original folder.

 


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