Issue Description

When deploying a package containing SharePoint artifacts and selecting the Use Existing option on SmartObjects, attempting to access the deployed K2 application results in an error.

Error Message

The following message will display when attempting to open the K2 application:

Image

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and Install the K2 4.7 March 2018 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 March 2018 Cumulative Update FP12 from Regional Support.
  4. Install the K2 4.7 March 2018 Cumulative Update FP12 to apply the fix.
  5. It is recommended to refresh the browser cache.