Issue Description

When you update a SharePoint item multiple times using K2 smartforms in Runtime an error is presented

Error Message

The following error occurs: “Version conflict”

Cause

SharePoint caches list items client side and if this item gets updated indirectly (such as adding or removing attachments) the cached version of the list item is out of sync with the version of the item on SharePoint server.

Resolution

  1. Ensure you have K2 Five RTM installed.
  2. Get the K2 Five RTM FP28 from Regional Support.
  3. Install the K2 Five RTM FP28 to apply the fix.
  4. It is recommended to refresh the browser cache.
  5. You should now be able to continue working on your form without the error.