Introduction

K2 connect 5.1 includes enhancements and bug fixes for K2 connect. Take note of the following requirements when installing K2 connect 5.1 in your environment:

  1. Before installing K2 connect 5.1: Install the latest Cumulative Update and the latest Fix Packs. Minimum requirement for K2 Five is K2 Five September 2018 CU Fix Pack 02 and for K2 Five (5.1) it is K2 Five (5.1) Fix Pack 22.
  2. Installing K2 connect on an upgraded K2 Five environment: You must upgrade from K2 blackpearl 4.7 with the K2 for Visual Studio component installed and upgraded to K2 Five 5.1, and then upgrade to K2 connect 5.1.
  3. Installing K2 connect on a clean K2 Five environment: You cannot install K2 connect 5.1 in a clean K2 Five 5.1 environment. You must install K2 blackpearl 4.7 with  K2 for Visual Studio components first, and then install K2 connect 5.1.

Download

You can download the K2 connect installation package from the download’s page available on the K2 Partner and Customer Portal site. See the Installation details below for more information.

Download Now

Enhancements and Bug Fixes

The following enhancements and bug fixes have been made in this release:

  1. When installing K2 Five when only the K2 4.7 Visual Studio component is present an error stating “required product not found” displayed
  2. Installing K2 connect database with a hyphen in the name caused issues
  3. Updated ERP Connect files
  4. Ability to install K2 connect with SQL Azure
  5. When using K2 connect with SSO (Single Sign On), if your credentials do not exist in the SSO store SmartForms will prompt you to sign in. Once the credentials are stored, if the credentials become invalid (because of a password change in SAP) then SmartForms will only provide an error message and no option to re-enter the credentials. The error message states "RfcOpenConnection failed(RFC_LOGON_FAILURE): Name or password is incorrect. Please re-enter". 
     

Important Considerations and Behavioral Changes

  1. Before installing K2 connect 5.1 install the latest Cumulative Update and the latest Fix Packs. Minimum requirement for K2 Five is K2 Five September 2018 CU Fix Pack 02 and for K2 Five (5.1) it is K2 Five (5.1) Fix Pack 22.
  2. The SAP NetWeaver RFC libraries are required. The DLLs are not redistributed by SourceCode Technology Holdings, Inc. and must be obtained from services.sap.com. Once downloaded, you must copy the new NetWeaver RFC libraries to the correct system folders. The .zip files for each architecture (32 and 64-bit) contain four files, all of which are necessary.
    The 32bit files - copy to c:\Windows\SysWOW64
    The 64bit files - copy to c:\Windows\System32
  3. The installer updates both K2 connect 32-bit and 64-bit installations. One installer is used for new installations as well as for upgrades. When performing an upgrade, the current K2 connect version is uninstalled followed by the installation of the new version. Your existing settings are retained such as the K2 connect license key, however, it is important to select the correct database during installation.

Upgrading

Prerequisite:

  1. K2 blackpearl 4.7
  2. K2 Five 5.0 or 5.1
  3. K2 connect 4.7.1,4.7.2,4.7.3, 5.0
Steps to upgrade:

The following upgrade steps are required:

  1. Upgrade your K2 blackpearl 4.7 environment to K2 Five 5.1.
  2. Install the latest Cumulative Update and the latest Fix Packs. Minimum requirement for K2 Five is K2 Five September 2018 CU Fix Pack 02 and for K2 Five (5.1) it is K2 Five (5.1) Fix Pack 22.
  3. Download K2 connect 5.1 and install.
  4. Apply the K2 connect license key.
The installer updates both K2 connect 32-bit and 64-bit installations, and is used for new installations and upgrades. When performing an upgrade, the current K2 connect version is uninstalled followed by the installation of the new version. Your existing settings are retained such as the K2 connect license key, however, it is important to select the correct database during the installation.

Installation

Prerequisites:

  1. K2 blackpearl 4.7.
  2. SAP Netweaver RFC Libraries

Steps to install K2 connect 5.1:

The following steps are required for a clean install of K2 connect 5.1

  1. Install K2 blackpearl 4.7 with the K2 for Visual Studio component.
  2. Upgrade your K2 blackpearl 4.7 environment to K2 Five 5.1.
  3. Install the latest Cumulative Update and the latest Fix Packs. Minimum requirement for K2 Five is K2 Five September 2018 CU Fix Pack 02 and for K2 Five (5.1) it is K2 Five (5.1) Fix Pack 22.
  4. Download K2 connect 5.1 and install. The K2 Setup Manager guides you through the install.
  5. Apply the K2 connect license key.