Code Fix: An error occurs when executing the “Get Group Users” method from the UMUser SmartObject
KB002735
PRODUCT
Issue Description
When executing the “Get Group Users” method from the UMUser SmartObject for an Azure Active Directory security group, where the group name starts with a “ ” character, an error occurs.
Error Message
The following error occurs: “IdentityService.ProviderCacheIdentity:RoleProvider.GetGroup","64007 Provider did not return a result for AAD: GroupName on GetGroup".
Cause
The Azure Active Directory group was created with a white-space character in the beginning of the group name.
Resolution
- Ensure you have K2 Five (5.1) installed.
- Download the K2 Five (5.1) FP26 from K2 Partner and Customer Portal.
- Install the K2 Five (5.1) FP26 to apply the fix.
Considerations
Note that this fix contains a change in behavior.
We now allow a Security Provider’s Users and Groups to contain white-space characters to be saved as identities in the Identity.Identity table. Any implementations which are K2 FullyQualifiedName (FQN) dependent, may or may not experience instances where FQN values containing white-space characters now show up at end users which have not been allowed previously. No white-space adjustments are done and the name will be cached in the Identity.Identity table as is, which may result in duplications if any other white-space characters are used.