Issue Description

Smart actions on worklist notification emails does not action the worklist item.

Cause

When a network error occurs on an environment, and no timeout is specified in the EWS connection string, smart actions will wait infinitely.

Fix Description

If no timeout value is specified in the EWS connection string, a default timeout value of 120 seconds will be set.

Resolution

  1. Ensure you have K2 Five (5.1) installed.
  2. Download the K2 Five (5.1) FP27 from K2 Partner and Customer Portal.
  3. Install the K2 Five (5.1) FP27 to apply the fix.