Issue Description

When you deploy a legacy workflow containing a conditional start rule to the target environment, the conditional start rule does not deploy.

Resolution

    1. Ensure you have K2 Five (5.2) installed.
    2. Download and install the K2 Five (5.2) May 2019 Cumulative Update from K2 Partner and Customer Portal.
    3. Download the K2 Five (5.2) May 2019 Cumulative Update FP8 from K2 Partner and Customer Portal.
    4. Install the K2 Five (5.2) May 2019 Cumulative Update FP8 to apply the fix.

Considerations

After installing the fix pack, re-package the workflow on the source environment and deploy the workflow again to the target environment.