This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice This article is not considered official documentation for K2 software and is provided “as is” with no warranties.

Issue

In this scenario, the customer has existing K2 environments running on earlier versions of K2 that all point to one SharePoint tenant. However, if this customer would like to create a POC on this SharePoint server for a newer version of K2 (5.x), they cannot update the K2 for SharePoint App on their existing app catalog as this app version will be incompatible with existing 4.7 artifacts.

Symptoms

When attempting to point a 5.x server to a site collection using the existing App Catalog with the K2 blackpearl for SharePoint application, they will get the following error when attempting to register:

"A newer version of the K2 for SharePoint App is available."

Image

Troubleshooting Steps

To resolve this issue, the customer can create a second web application on the SharePoint server. With a secondary App catalog, the customer can now upload the K2 for SharePoint app that is compatible with versions 5.x for POC while still using 4.7 artifacts on their original web application.

For more instructions on how to add the K2 for SharePoint app to multiple App catalogs, please see the following documentation: http://help.k2.com/onlinehelp/k2five/userguide/5.2/default.htm#k2-for-sharepoint/addappmultiappcat.htm