Greetings!

With the next release of K2 blackpearl (4.7), we will be removing support for several third-party products, as many of these are product versions no longer supported by the original product vendor. As such, any issues found with these older versions will not be eligible for code fixes by K2.

Note: K2's latest support policies are described in more detail in the K2 Product Support and Release Strategy, located at http://help.k2.com/k2releasestrategy.
You may refer to the K2 blackpearl and K2 smartforms: Product Compatibility, Integration and Support article for more details on support for specific versions of software.

  • If you are installing a new, clean K2 environment, you should ensure that you are on supported versions of technologies required for your installation, such as Windows operating systems or database versions.

  • If you are using any of the technologies flagged as Blocked by Installer, you will not be able to upgrade existing environments or install on new, clean environments until you have upgraded the technology to a supported version.

  • If you are using multiple K2 databases, you will be required to consolidate them to a single database before you can upgrade. For more information, see http://help.k2.com/kb001628

  • If you are upgrading your existing K2 environment, you will be able to do so as long as the technology version is not flagged as Blocked by Installer. However, issues found related to the underlying technology product will not be eligible for code fixes.

  • If you have solutions that integrate with older, no longer supported technologies, you should consider upgrading those systems and modifying your solutions to use the updated, supported integrations.

  • To remain supported, K2 encourages our customers to upgrade to the latest Minor Release, K2 4.7 when it is available, or the latest update on the previous Minor Release, K2 4.6.11. This will ensure that you are able to receive code fix support if necessary. For more information, see http://help.k2.com/news/upgrading

With the K2 4.7 release, the following will apply:

Technology Supported No Longer Supported
(*Blocked by Installer)
Windows Operating System Windows Server 2012 R2
Windows Server 2012
Windows 10
Windows 8.1
Windows Server 2008 R2
Windows Server 2008
*Windows 8.0
*Windows 7
*Windows Vista
.NET Framework .NET 4.6.1
.NET 3.5 SP1
*.NET 4.5.x
*.NET 3.0
*.NET 2.5
PowerShell PowerShell 5
PowerShell 4
PowerShell 3
*PowerShell 2
*PowerShell 1
IIS IIS 8.0 IIS 7.0
IIS 7.0 with IIS 6.0 backwards compatibility
Browser IE 11
Google Chrome (latest version)
Mozilla Firefox (latest version)
Apple Safari (latest version)
Silverlight 5
IE 10
IE 9
IE 8
IE 7
Silverlight 4
SQL Server Azure SQL Standard 200 or Higher
SQL Server 2016
SQL Server 2014
SQL Server 2012
Microsoft Report Viewer 2012
SQL Server 2008 R2
SQL Server 2008
Microsoft Report Viewer 2008 SP1
K2 database Single database *Multiple databases
SharePoint SharePoint Online
SharePoint 2016
SharePoint 2013
SharePoint 2013 in 2010 Mode
SharePoint 2010
Forms Server 2010
Excel Services 2010
Word Automation Services 2010
*MOSS 2007
*WSS 3.0
*Forms Server 2007
Office Office 2016
Office 2013
Office 2010
Office 2007
InfoPath 2013 in 2010 Mode
InfoPath 2010
InfoPath 2007
Visual Studio Visual Studio 2015
Visual Studio 2013
Visual Studio 2012
Visual Studio 2012 Web Deployment Projects
Visual Studio 2010
Visual Studio 2010 Web Deployment Projects
*Visual Studio 2008
Exchange Exchange Online
Exchange 2016
Exchange 2013
Exchange 2010
Exchange 2007
CRM Dynamics CRM Online
Dynamics CRM 2016
Dynamics CRM 2015
Dynamics CRM 2013
Dynamics CRM 2011
Dynamics CRM 4
Oracle Oracle 12c
Oracle 11g
Oracle 10g
Oracle 9i
SAP SAP R/3 4.6c or greater
SAP NetWeaver RFC libraries
*Classic RFC libraries

Please contact your K2 Account Manager should you have any specific questions.

K2 Product Team