We are excited to announce the newest releases of K2 Connect, which allows you to consume SAP BAPIs as SmartObjects in your K2 solutions.

K2 Connect 5.0 is compatible with K2 Five and provides a number of enhancements and bug fixes.

In addition, we have released K2 Connect 4.7.2, providing a number of bug fixes for K2 Connect 4.7.

For more details on these releases, please read the following Release Notes:

Next Steps and Important Considerations

Download the installer. Please visit the K2 Customer and Partner Portal to download the installer for either K2 Connect 4.7.2 or K2 Connect 5.0.


Important Note: Developers will first need the K2 blackpearl 4.7 client tools, specifically the K2 for Visual Studio component, before upgrading to K2 Connect 5.0. For more information, please see the release notes.

 

Submit your ideas. Don't forget that you can submit feature requests and feedback directly to us on the K2 Ideas Forum.