< class="prominent-subhead ">

Activating K2 for SharePoint Error

~~repeating-content.html~~
This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue

When activating the K2 application on the desired sites after an upgrade to K2 4.7, an error may appear.

Image

Symptoms

Activating the K2 for SharePoint application will fail with an error:

 “Serviceobject : [Management_k2Application]. Method : [RemoveK2AppFromSite]’

Resolution

This issue could be caused if the K2 for Sharepoint App has not been updated after the K2 Environment was updated to K2 4.7.

Please verify that your K2 for Sharepoint App is running on the same version as the K2 environment. If you're running the old version, rerun the App deployment from the K2 SmartForms Setup Manager.  For more information please see this article.

If you're still experiencing this issue, please contact K2 Support.