< class="prominent-subhead ">

Error when trying to access the K2 for SharePoint application

~~repeating-content.html~~
This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue

When attempting to open the K2 for SharePoint app from a list/library, the following error appears: "This content cannot be displayed in a frame". You will not be able to proceed from here and all lists/libraries within this site collection will display the same error. This is only specific to one or certain site collections and the rest work perfectly as expected.

Symptoms

The connection was broken between K2 and certain site collections. A possible cause could be that the SharePoint 2013 Service Instance was manually refreshed by a user in the tester tool.

Troubleshooting Steps

The broken connection was repaired by removing and re-adding the K2 app to the problematic site collection.

From the AppCatalog level:

1. Remove the site collection from the Manage App Activations page.

2. Remove the site collection from the Manage App Deployments page.

3. Re-add the site collection in the Manage App Deployments page.

4. Re-activate the site collection in the Manage App Activations page. This will prompt you to also re-trust the K2 for SharePoint application. The broken connection was now successfully re-established and the K2 app now works as expected within the site collection.