This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice This article is not considered official documentation for K2 software and is provided “as is” with no warranties.

Issue

Previously, K2 Designer in Visual Studio pointed to an old K2 server, and it was changed to a new K2 server. It was verified that the SmartObject Server environment field in Workspace and the K2 Blackpearl server is pointing correctly to the new server. But visual studio couldn't deploy K2 connect server to the new K2 server.

Symptoms

In Visual Studio, when opening the K2 Service Object Designer and selecting the K2 Blackpearl Settings icon, it is pointing to the correct new server. But, there is a message 'Valid K2 connect Server information not found' as below:

Image

Troubleshooting Steps

To resolve this:

1. Verify which SmartObject Server environment field in your Environment Library is pointing to the New server.

2. Verify that Visual Studio is connected to a New K2 environment. In that case:

a. Open the K2 Object Browser

b. Click on the arrow besides the Environment header

c. Select Change Server

d. Change the server to the new Environment's server

3. If you complete the steps above, but still see the same error, try to reinstall the client tools. At the K2 Connect database setting page, specify the K2 Connect database new server name. The database name should be the default K2Connect.

4. After reinstalling the client tools successfully, specify the Destination under the Development Kit.