Issue

You are unable to deploy packages on a environment and an error appears.

”This package was created on a version that is no longer supported on this target Environment. In order to deploy this solution to this target environment, upgrade the source environment to align with the same version as the target and repackage the solution. Then reattempt deploying this package”

Symptoms

Although the Source and Target environments are on the same K2 Five FP8 or earlier, deployment is not possible and the error appears.

Resolution

To resolve this issue, please install K2 Five RTM FP11 or later as this includes a fix for the product version check logic.