Issue

The following error appears after selecting a package for deployment using K2 Package and Deployment:

"Unsupported schema version 15 - version 14 or earlier is supported. Please update to the latest version. Parameter name: xml"

Symptoms

In this case, the following KB articles did not help to resolve the issue.

From the [K2].[HostServer].[UpdateHistory] table, both the Source and Target environments have the same K2 4.7 Cumulative Update and Fix Pack installed.

Troubleshooting Steps

To resolve the issue, please re-install the same 4.7 Cumulative Update and Fix Pack on the Source and Target environments.