< class="prominent-subhead ">

Unable to deactivate K2 from Site Collection

~~repeating-content.html~~
This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue

There is a problem with a SharePoint site which has become 'orphaned.'
The K2 App was removed from the site but it is still showing as 'activated'. 

Symptoms

This issue prevents using the Package and Deployment tool to deploy a package to the site. This is caused  by the orphaned K2 integration.

Resolution

Please use the following steps to deactivate the site and remove K2 integration:

1. Using SmartObjectTester tool:
Go to System > SP 2013 integration > SP Integration Helper Methods SmartObject
Execute "deactivate Site collection" method.
2. Activate the Site Collection from SharePoint.
3. Go to App Catalog > Open K2 App > Manage app activation > Uninstall the site.

The package will now deploy successfully.