This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice This article is not considered official documentation for K2 software and is provided “as is” with no warranties.

Issue

When opening up the Legacy K2 Workspace Site, the page does not load and only a blank white screen is displayed.

Image

Symptoms

When the issue is encountered and the Browser F12 Console - Network Log is monitored, an outgoing request to /Workspace/Navigation/Navigation.aspx is observed. The Request remains on a status of (Pending...)

No further messages or errors are logged.

Troubleshooting Steps

The issue can be caused by an unsuccessful attempt by the Workspace Site to connect to the LDAP server.

A possible resolution to the issue, is to make the following configuration changes to the Workspace web.config file:

- Go to the [Program Files]\K2 blackpearl\Workspace\Site folder

- Open the web.config file in a Text Editor

- Search for the <connectionStrings> section

- Modify the connectionString by adding the port Number: <add name="ADConnectionString" connectionString=LDAP://fulldomainname /> becomes <add name="ADConnectionString" connectionString=LDAP://fulldomainname:389 />

- Save the web.config and access the Workspace Site again.

The Default port number used for LDAP is port 389. Should a different port number be used in your infrastructure, please use this number instead.

Please also refer to the following KB Article regarding Trusted Site and Compatibility View Settings related to K2 Workspace and Internet Explorer 11: https://help.k2.com/kb001578.