< class="prominent-subhead ">

Error on secondary Runtime site after upgrade to 4.7

~~repeating-content.html~~
This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue

After upgrading to 4.7, forms opened from the secondary runtime site are displaying the error below:

"Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

Could not load file or assembly 'Telerik.Web.UI, Version=xxx, Culture=neutral, PublicKeyToken=xxx' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference (Exception from HRESULT: 0x80131040)"

Symptoms

The secondary runtime site was set up prior to the upgrade based on the following KB: How to set up a secondary SmartForms Runtime site for Anonymous Access

The copied Smartforms runtime folder will not be updated on upgrade, only the original Smartforms runtime folder will be affected during this process.

Troubleshooting Steps

Re-do the steps in the abovementioned KB so that the updated contents of the Smartforms runtime site will be copied over to the secondary runtime site. This should resolve the issue.