Issue

After upgrading to 4.7, forms opened from the secondary runtime site are displaying the error below:

"Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

Could not load file or assembly 'Telerik.Web.UI, Version=xxx, Culture=neutral, PublicKeyToken=xxx' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference (Exception from HRESULT: 0x80131040)"

Symptoms

The secondary runtime site was set up prior to the upgrade based on the following KB: How to set up a secondary SmartForms Runtime site for Anonymous Access

The copied Smartforms runtime folder will not be updated on upgrade, only the original Smartforms runtime folder will be affected during this process.

Troubleshooting Steps

Re-do the steps in the abovementioned KB so that the updated contents of the Smartforms runtime site will be copied over to the secondary runtime site. This should resolve the issue.