< class="prominent-subhead ">

Changing SharePoint site title causes loading hang on App Activation page

~~repeating-content.html~~
This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue

After changing the SharePoint site title, pages such as Manage App Deployments and Activate Site Collection hang indefinitely on "Working on it".

Image

Symptoms

Indefinite loading on App Management pages. When an F12 trace is run on this loading page you will see the following console error:
"Uncaught error: Sys.ParameterCountException: Parameter count mismatch."

Troubleshooting Steps

If you are experiencing this issue, contact a K2 Support engineer who will check your environment and verify if this is a known issue. From there, you will be provided a new K2 for SharePoint App from our Labs team that you can re-add to resolve this.

Please note that if you are experiencing a DNS error when attempting an App Deployment for this new app, this could be because you have updated your site URL without linking it to the correct server. Please make sure all updated site URLs are linked correctly.