This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice This article is not considered official documentation for K2 software and is provided “as is” with no warranties.

Issue

When you have built an automated workflow on K2 version 4.7 (Legacy) within SharePoint and then upgrade the environment to 5.2 the workflow no longer starts as expected as this is supposed to start once an Item is added to a list. 

This does start if you execute this manually. Also, if the workflow is created on the new designer in 5.2, this starts as expected once an item is added to the a Sharepoint list. 

Symptoms

The error that is seen from the Event Viewer and Host Server Logs is the following:

[Error details]:

An unexpected error has occured while trying to resolve a value for Resolver ID 106C5886-18B1-4c09-BEB3-6F7342669D18. [Assembly]: SourceCode.EventBus.SharePoint15.ProcessStarter, Version=4.0.0.0, Culture=neutral, PublicKeyToken=16a2c5aaaa1b130d [
Class]: SourceCode.EventBus.SharePoint15.ProcessStarter.ProcessStarter
[Method]: StartProcess [Inner exception details]: An unexpected error has occured while trying to resolve a value for Resolver ID DCAB9253-08BC-4B14-A7B8-AD1D972642D9.
[Stack trace details]: at SourceCode.Framework.Data.ResolverManager.GetValue(String runtimeData) at SourceCode.EventBus.SharePoint15.ProcessStarter.ProcessStarter.StartProcess(String hostName, String connStr, String processFullname, String folio, Boolean synchronous, String fieldsXml, String impersonateUser, Int32 defaultVersion, Int32 priority) [Verbosity]: Detailed

Resolution

Fixpack 10 for K2 5.2. resolves this issue. This can be downloaded below:
https://portal.k2.com/products/k2five5-2fix-pack10