This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice This article is not considered official documentation for K2 software and is provided “as is” with no warranties.

Issue

When clicking on the Viewflow of a process, you receive a 404 error and are unable to proceed. 

You may try to clear your browser cache, close the browser and also try other browsers such as Internet Explorer, Google Chrome or Mozilla Firefox, but these all present the same result. 

This appears after upgrading to K2 version 5.2. 

Symptoms

You will notice by looking at the viewflow url that it is pointing to an older version (legacy version). When looking within IIS under the K2 category tree for SmartForms, you will see the correct viewflow path url. However, this may be outside the main K2 stack tree.

Troubleshooting Steps

Within IIS, if you have separate tree stacks for SmartForms this may be the cause of the issue. In the new K2 versions, K2 normally consolidates all the K2 sites and applications within IIS to be under one tree stack, unless a custom set up is done.  

A new realm would have to be set up for the correct viewflow url, which can be done within the management page by going to the following path: 

Image

Additional steps 
Within IIS under the runtime site, you will see that there is no viewflow site here (compared to the one under the K2 sites stack). This can be created by grabbing the new viewflow url directory from the K2 site stack and copying in the new url  to point to. 
Once completed, refresh the page and this should work as expected when trying to access the viewflow of the process.