This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice This article is not considered official documentation for K2 software and is provided "as is" with no warranties.

Issue

When attempting to upgrade K2 version 5.3 from a previous K2 Five version, you will see that just after you select which components you would like to install that the initial process gets halted.

It appears that there is a required dependency and without it you cannot proceed with the upgrade.

Symptoms

The dependency/error being presented within the installation is the following:


Visual Studio 15 is a required dependency…..


Potentially Visual Studio did exist on the environment, but may have been removed. However, K2 may think that it still exists due to the K2 for Visual Studio component from a previous installation still present. To verify this it would be best to check the control panel to see if this is the case.

Resolution

This issue has been identified as a bug and will be addressed within a future release version of K2.

Workaround
Re-install Visual Studio then complete one of the following options:

Option 1
Launch the current environments' K2 set up manager and choose the modify option to remove the K2 for Visual Studio component. Continue until this has been completed and restart the upgrade to 5.3.

Option 2
You may continue on with the original 5.3 upgrade installation. Launch the set up manager, choose the modify option and remove the K2 for Visual Studio component. After this, K2 for Visual studio can be removed entirely.