< class="prominent-subhead ">

All K2 sites are loading blank with no styling, and a MIME type error is seen in browser Dev Tools (F12)

~~repeating-content.html~~
This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.

Issue

All K2 sites are loading blank and appear to have no styling associated with them.  This is generally seen during the original setup of a new K2 server, or if permissions have changed with the K2 Service Account.

Symptoms

All K2 sites such as Management, Designer, Workspace, and Runtime, will be showing as a blank page with no styling.  When opening the F12 error console, you will see an error message similar to the following:

"Refused to apply style from 'company site/CombinedResource.ashx?d= because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled."

You might also notice one or several http 500 Internal Server errors that are thrown on calls to 'CombinedResource.ashx?d,' either in a network browser trace or the Windows Event Log.  An example from the Windows Event Log:

"Failed to get resource: /Management/Styles/Themes/Platinum2/SourceCode.Forms.Controls.Web.ManagementControlPack.AssetControl.Resources.Styles.Main.css?_v=5.1008.19172.2 Exception: SourceCode.Forms.AppFramework.AsyncException: Asynchronous operation failed ---> System.Net.WebException: The remote server returned an error: (500) Internal Server Error."

Troubleshooting Steps

To resolve the issue, confirm that the associated K2 Service account has the required listed folder permissions here:  https://help.k2.com/onlinehelp/K2Five/ICG/5.3/default.htm#Plan/Required-Permissions.htm

Please see the below example of Service Account permissions on the \K2\Host Server\Bin folder: