Code Fix: An error occurs when creating a new version of a View or Form by deploying a package

  • 16 February 2021
  • 0 replies
  • 8 views

Badge +6
 

Code Fix: An error occurs when creating a new version of a View or Form by deploying a package

KB001811

PRODUCT
K2 smartforms 4.7
BASED ON
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue Description
When creating a new version of a View or a Form by deploying a package an error occurs stating that an item with the same key has already been added.
 

Error Message
“An item with the same key has already been added”.
The following error is logged in the K2 HostServer log: “DeploymentServer","30003","DeploymentError","SourceCode.Runtime.Services.Forms","30003 An item with the same key has already been added."
 

Cause
The logic that merges the new version of the View with the old version, changed the GUIDS of 2 cells to the same GUID.
 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Install the K2 4.7 February 2017 Cumulative Update.
  3. Get the K2 4.7 February 2017 Cumulative Update FP1 from Regional Support.
  4. Install K2 4.7 February 2017 Cumulative Update FP1 to apply the fix.

 


0 replies

Be the first to reply!

Reply